USB-Link™

IDSC Holdings LLC retains all ownership rights to USB-Link and its documentation. The USB-Link source code is a confidential trade secret of IDSC Holdings LLC. You may not decipher or de-compile USB-Link, develop source code for USB-Link, or knowingly allow others to do so. USB-Link and its documentation may not be sublicensed or transferred without the prior written consent of IDSC Holdings LLC.

This manual, as well as the software it describes, is furnished under license and may only be used or copied in accordance with the terms of such license. The content of this manual is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by IDSC Holdings LLC. IDSC Holdings LLC assumes no responsibility or liability for any errors or inaccuracies that may appear in this book.

Except as permitted by such license, no part of this publication may be reproduced, or transmitted, in any form or by any means, electronic, mechanical, or otherwise, without the prior written permission of IDSC Holdings LLC.

NEXIQ Technologies is a trademark of IDSC Holdings LLC.

©2010 IDSC Holdings LLC. All rights reserved. All other marks are trademarks or registered trademarks of the respective holders. Pictures for illustration purposes only. Specifications are subject to change without notice.

www.nexiq.com

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) this device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause undesired operation. This device contains FCC-ID POOWML-C30XX.

approved in accordance to R&TTE directive transmitter module marked by “CE product label”, manufactured by MITSUMI incorporated to OEM product.
Chapter 1: Introducing the USB-Link™ ................................................. 1
  Product Specifications ...................................................................... 2
  System Requirements ..................................................................... 3
  USB-Link™ Components ................................................................ 4
  Communication Options: Wireless or Wired? ............................... 5
    Wireless Connection .................................................................... 5
    Wired Connection ...................................................................... 7

Chapter 2: Installation and Bluetooth Configuration ................... 9
  Installation Process Flowchart ...................................................... 10
  Outline of Installation Process .................................................... 11
  Step 1: Install the USB-Link™ Drivers and Utilities ................... 12
  Step 2: Choose Your Connection ............................................... 20
    Wired Connection ................................................................... 20
    Wireless Connection ............................................................. 21
  Step 3: Install the Bluetooth Drivers ....................................... 22
    Instructions for Windows XP Users .......................................... 22
    Instructions for Windows 7 Users ............................................ 29
  Configure the Bluetooth Environment ..................................... 30

Chapter 3: Preparing to Use the USB-Link™ ............................ 33
  Step 4: Connect the USB-Link™ to a Vehicle ......................... 34
    Making the Connection ........................................................ 35
    Wired Connection Using a USB Cable .................................. 35
    Wireless Connection ............................................................ 36
  Step 5: Pair the Device ............................................................ 37
    Instructions for Windows XP Users ........................................ 37
    Instructions for Windows 7 Users .......................................... 41
Table of Contents

Step 6: Test the Connection to the Vehicle ................................................. 48

Step 7: Setting Up Diagnostic PC Applications ........................................ 51
  Allison DOC™ for Fleets (1000/2000) .................................................. 51
  Allison DOC™ for Fleets (3000/4000) .................................................. 52
  Allison DOC™ for PC (update) ............................................................... 52
  Bendix Acom™ Diagnostics ................................................................. 53
  Caterpillar Electronic Technician .......................................................... 55
  Cummins INSITE™ ............................................................................. 58
  Detroit Diesel Diagnostic Link (DDDL)™ ............................................. 61
  DDEC 7.0 .......................................................................................... 62
  Eaton Service Ranger ........................................................................... 63
  HINO Diagnostic eXplorer ................................................................. 65
  International® ABS ............................................................................ 67
  International® INTUNE ....................................................................... 69
  International® Three, Single, and Dual Box ....................................... 69
  Meritor WABCO® Toolbox .................................................................. 71

Chapter 4:
USB-Link™ Troubleshooting Information .............................. 73
  LED Issues .................................................................................. 74
  Configuration Issues ..................................................................... 76
  Wireless Communication Issues .................................................... 76

Appendix A:
USB-Link™ Adapter and Cable Guide ................................. 77
  Choosing the Right Cable Adapter ............................................... 78
  Adapter Drawings ........................................................................ 79
Chapter 1

Introducing the USB-Link™

- Product Specifications, page 2
- System Requirements, page 3
- USB-Link™ Components, page 4
- Communication Options: Wireless or Wired?, page 5

The USB-Link™ is a hardware device that enables service bay personal computers (PCs) to retrieve vehicle information using either wireless Bluetooth® technology or a more traditional cable connection. Once configured, the USB-Link™ interfaces with your PC, enabling you to use specific PC applications to perform vehicle diagnostics.

This chapter introduces the USB-Link™ and provides details regarding the communication modes available to you to interface with your PC.
### Product Specifications

The USB-Link™ is configured with the following specifications:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Data</th>
</tr>
</thead>
</table>
| Physical Dimensions          | 5.86” x 3.02” x 1.78”  
(149 mm x 77 mm x 45 mm) |
| Weight                        | 4.6 oz. (0.13 kg)                                                   |
| Power Requirements            | 10 - 32 VDC @ 350 mA maximum                                        |
| Operating Temperature         | 0 to +70 °C                                                         |
| API Driver                    | TMC RP1210A and RP1210B compliant  
SAE J2534 compliant          |
| Vehicle Protocols Supported  | • J1708/J1587  
• J1939 (250K, 500K, or 1 MB)  
• CAN (125K, 250K, 500K, 1 MB)  
(Dual CAN supported)  
• J2284 CAN (125K, 250K, or 500K)  
• ATEC-160 Baud  
• ALDL Pass-through  
• ALDL 8192  
• ALDL 9600  
• OBDII  
• ISO 9141  
• ISO 14230 (KWP2000)  
• ISO 15765  
• J1850 (PWM, VPM, or Allison)  
• J1939 Auto Baud  
• IESCAN (required for Allison) |
| USB Communication             | USB Device, version 1.1                                              |
| Wireless Communication        | Bluetooth® Class 1 adapter (up to 100 m range)                      |
| Wired Communication           | USB cable 15 ft. (5 m) maximum                                      |
| Vehicle Connector             | DB15F                                                               |
| USB Connector                 | Type B jack                                                         |
# System Requirements

Be aware of the following system requirements:

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
</table>
| IBM PC-compatible computer              | • 1GHz processor or more  
• RAM: 256MB or more (512MB recommended)  
• USB port, version 1.1 or higher       |
| Operating system                        | • Windows® XP  
• Windows® 7  

*Note:* USB-Link™ drivers support the Windows® 7 operating system. However, not all OEM PC applications work with Windows® 7.

| Bluetooth® adapter (sold separately)   | • Bluetooth® serial port capability  
• Must support WIDCOMM® drivers, 1.4x and higher  

The USB-Link™ has been qualified with the following Class 1 adapter:  
- IOGEAR® GBU321
USB-Link™ Components

The following illustration details each of the USB-Link™ components:

![USB-Link™ Components Diagram]

Figure 1.1 USB-Link™ Components
Communication Options: Wireless or Wired?

Prior to using the USB-Link™, you need to decide how you want the unit to communicate with your PC. There are two options:

- Wireless connection to the PC using Bluetooth® (pg. 5)
- Wired connection to the PC using a USB cable (pg. 7)

**Wireless Connection**

A wireless connection provides the advantage of untethered communication.

Wireless connectivity provides untethered operation, and that’s a bonus in a busy service bay. USB-Link™ uses Bluetooth® wireless technology to provide this wireless communication between the USB-Link™ and your PC.

**NOTE:**

The USB-Link™ does not support Integrated Bluetooth. If your PC has Integrated Bluetooth, your system has Bluetooth® drivers installed and a built-in Bluetooth® transceiver. You must uninstall Integrated Bluetooth and its Bluetooth® drivers prior to proceeding with the USB-Link™ installation process.
If your PC does not have Integrated Bluetooth, then you are clear to proceed with the USB-Link™ installation process as documented in this manual:

- Install Bluetooth® drivers
- Install an external Bluetooth® adapter

**NOTE:**

For detailed information on installing Bluetooth® drivers and configuring a basic Bluetooth® environment, refer to Chapter 2: **Installation and Bluetooth Configuration**, later in this manual.

- Pair the device
  - Instructions for Windows XP Users
    (using the NEXIQ™ Bluetooth Connection Utility, refer to **Chapter 3: Preparing to Use the USB-Link™**, later in this manual.)
  
  - Instructions for Windows 7 Users

**NOTE:**

The USB-Link™ is intended for diagnostic use, for example, retrieving trouble codes. By nature, Bluetooth® wireless technology has limited bandwidth and latency when compared to wired solutions. This may result in dropped messages in situations requiring high bandwidth.
Wired Connection

A wired connection provides the advantage of faster data throughput.

Using a USB connection to the PC is highly recommended when diagnosing heavily-loaded CAN/J1939 buses. By nature, Bluetooth® has less bandwidth than USB, which can result in dropped messages in situations requiring high bandwidth. ECU reprogramming typically requires both high throughput and critical timing, and should always use a USB-to-PC wired connection.

Wired communication between the USB-Link™ and your PC requires a USB cable.

Figure 1.3 Wired Connection

Figure 1.4 15 ft. USB Cable
Chapter 2

Installation and Bluetooth Configuration

- Step 1: Install the USB-Link™ Drivers and Utilities, pg. 12
- Step 2: Choose Your Connection, pg. 20
- Step 3: Install the Bluetooth Drivers, pg. 22
  - Instructions for Windows XP Users, pg. 22
  - Instructions for Windows 7 Users, pg. 29
  - Configure the Bluetooth Environment, pg. 30

This chapter provides instructions for installing NEXIQ™ drivers and utilities, installing the required Bluetooth® drivers, installing a Bluetooth® adapter, and configuring a basic Bluetooth® environment.
Installation Process Flowchart

- Install NEXIQ Drivers
- Wireless? (Yes/No)
  - Yes: Install BT Drivers, Install BT Adapter, Configure BT Environment, Connect to Vehicle (Physical), Pair the Device, Test the Connection, Set Up Diagnostic Apps
  - No: Connect to Vehicle (Physical)

Figure 2.1 Process Flowchart
Outline of Installation Process

**Step 1:** Install the NEXIQ™ USB-Link™ drivers and utilities *(pg. 12).*

**Step 2:** Choose your connection (wired or wireless) *(pg. 20).*

If you chose a wired connection, move on to complete steps 4, 6, and 7 only.

**Step 3:** Install the drivers for the Bluetooth® adapter you are using (e.g., the IOGEAR® GBU321 adapter).

- Instructions for Windows XP Users *(pg. 22)*
- Instructions for Windows 7 Users *(pg. 29)*

**Step 4:** Connect the USB-Link™ to the vehicle.

**Step 5:** Pair the Device:

- Instructions for Windows XP Users
  (using the NEXIQ™ Bluetooth Connect Utility).

- Instructions for Windows 7 Users

**Step 6:** Use the NEXIQ™ Device Tester to test the connection between the USB-Link™ and the vehicle.

**Step 7:** Set up diagnostic PC applications that apply to your local environment for use with the USB-Link™.

**NOTE:**

Steps 4 through 7 are described in Chapter 3 of this manual.
Step 1: Install the USB-Link™ Drivers and Utilities

Prior to using the USB-Link™ it is necessary to install the required NEXIQ™ device drivers and utilities on your PC or laptop. These device drivers are compatible with Microsoft® Windows® XP and Windows® 7.

**IMPORTANT:**

⚠️ Remember, you must have Administrator security rights and be logged in as “Admin” to successfully complete the installation process outlined in this manual.

**NOTE:**

ℹ️ If you have questions about using this product, contact NEXIQ™ Technical Support at (800) 639-6774, or send us an e-mail at: support@nexiq.com.

To install the device drivers and utilities:

1. Close all programs and insert the NEXIQ™ USB-Link Drivers CD into your PC’s CD-ROM drive.

![Installation Welcome! Screen](image)
If the program does not automatically start, access your CD-ROM drive through My Computer and double-click the SETUP.EXE file.

2 Read the information displayed on the Welcome! screen, and click Next.

The Copyright Notice screen is displayed.

![Copyright Notice Screen](image)

**Figure 2.3 Copyright Notice Screen**

3 Read all the information on this screen, then click I Accept.

**NOTE:**

If you do not agree to the terms, click I Decline. A message is displayed prompting you to confirm exiting the installation. Click EXIT SETUP.
The Backup Replaced Files? screen is displayed.

4 Do one of the following:
   — Click Yes if you wish to back up copies of files replaced during the installation (recommended).
   — Click No if you do not wish to back up files.

5 Click Next to continue.
If you chose to back up replaced files, the installation program requests a location to store the files.

![Select Backup Directory Screen](image)

**Figure 2.5 Select Backup Directory Screen**

6 Do one of the following:

— To accept the default directory, click **Next** and proceed to Step 7 (recommended).

— To select a different directory, click **Browse**...

At the bottom of the screen, select the desired drive letter from the drop-down list. Double-click each directory to add to the path. Click **OK** to proceed.

The program returns to the **Select Backup Directory** screen. Confirm the destination, then click **Next**.
7 Wait for the **Ready to Install** screen to appear.

![Figure 2.6 Ready to Install Screen](image)

**NOTE:**

Be sure to disconnect all RP1210A adapters currently connected to the PC before proceeding with the installation.

8 Do one of the following:

— Click **Next** to proceed with the installation.
— Click **Back** to step backward through previous screens.
— Click **Cancel** to stop the installation.
A dialog box displaying a status bar is displayed indicating percentage complete.

![Status Bar](image)

**Figure 2.7 Status Bar**

If Microsoft® .NET Framework is *not* found on your PC, the following dialog box is displayed.

![.NET Framework Dialog Box](image)

**Figure 2.8 .NET Framework Dialog Box**

9 Click **OK**, and follow the prompts to install the .NET software.

Once the .NET installation is complete, the following message is displayed:

*Installation of Microsoft .NET Framework 1.1 is complete.*

10 Click **OK** to continue.
If you are running Windows 7, the following screens may be displayed.

**NOTE:**

If you are running Windows XP, move on to Step 11 (pg. 19).

Click **Install** to continue.

![Figure 2.9 Windows 7 Security Message](image)

Click **Install this driver software anyway**.
11 Wait for the **Installation Completed!** screen to appear.

![Installation Completed! Screen](image)

**Figure 2.11** *Installation Completed! Screen*

12 Click **Finish**.

A message appears prompting you to restart the PC.

![Restart Prompt](image)

**Figure 2.12** *Restart Prompt*

13 Click **OK** to restart the PC.

14 Once the PC restarts, remove the installation CD from the CD-ROM drive.

Move on to “Choose Your Connection,” next in this manual.
Step 2: Choose Your Connection

You have two options for connecting the USB-Link™ to a PC or laptop computer.

- Wired connection using a 15 ft. USB cable
- Wireless connection using Bluetooth®

Choose one of the following options. Both have advantages.

Wired Connection

The advantage of a wired connection is faster throughput (e.g., you want to use the USB-Link™ for ECU reprogramming).

![Figure 2.13 Wired Connection Using USB Cable](image)

NOTE:

If you are connecting the USB-Link™ by means of a USB cable, you do not need to read the rest of this chapter. Instead, move on to “Connect the USB-Link™ to a Vehicle” in Chapter 3 of this manual.

If you choose a wired connection, you may still want to install the Bluetooth® drivers now rather than later. This will give you the flexibility of wireless connectivity at some time in the future. To install the Bluetooth drivers now, continue reading the remainder of this topic. Otherwise, move on to Chapter 3.
Wireless Connection

The advantage of a wireless connection is, of course, untethered operation.

For a wireless connection using Bluetooth® technology, you must:

- Insert the USB Bluetooth Adapter CD into your PC’s CD-ROM drive.
- Install the necessary Bluetooth® drivers.
- Plug the Bluetooth® adapter (i.e., the dongle) into an available USB port on your laptop.

Move on to “Step 3: Install the Bluetooth Drivers” next in this manual.
Step 3: Install the Bluetooth Drivers

The USB-Link™ has been qualified with the following Class 1 (100 m range) Bluetooth® USB adapter:

- IOGEAR® GBU321

Class 1 adapters are recommended because of their greater operating range.

There are two methods for installing the drivers:

- Instructions for Windows XP Users (pg. 22)
- Instructions for Windows 7 Users (pg. 29)

Instructions for Windows XP Users

To install the Bluetooth® drivers:

**NOTE:**

Make sure that the IOGEAR Bluetooth adapter is **NOT** plugged into the laptop before installing the software.

1. Insert the IOGEAR installation CD into your PC's CD-ROM drive.

![WIDCOMM Bluetooth Software Dialog](image)

*Figure 2.15 WIDSOMM Bluetooth Software Dialog*

2. Click **Yes**.
The Welcome to the InstallShield Wizard screen is displayed.

3 Click Next, and follow the on-screen prompts.
The License Agreement screen is displayed.

![License Agreement screen](image)

**Figure 2.18 License Agreement screen**

4 Click the **I accept the terms in the license agreement** button.

5 Click **Next** to continue.
The **Destination Folder** screen is displayed.

![Figure 2.19 Destination Folder Screen](image)

6 Click **Next** to install the folder.
The **Ready to Install the Program** screen is displayed.

7 Click **Install** to begin the installation.

8 Wait while the InstallShield Wizard installs the software.

   A status bar provides an indication of how close the wizard is to completing the installation. The process may take several minutes.
The Bluetooth device not found message is displayed.

9 Plug the IOGEAR Bluetooth adapter into an available USB port on your laptop, and wait while the wizard installs the adapter.

10 Click Finish to exit the wizard.
11. Remove the installation CD from the CD-ROM drive.

12. Move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 3.

NOTE:

If you have installed the IOGEAR Bluetooth adapter, you do not need to perform the last two procedures in this chapter. Move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 3.

If You Installed a Different Class 1 Adapter

If you installed a Class 1 Bluetooth adapter other than the IOGEAR adapter (e.g., a Belkin adapter), the adapter may require you to configure a Bluetooth environment. If this is necessary, an Initial Bluetooth Configuration Wizard screen will display at the conclusion of the adapter installation process.

If this happens, move on to “Configure the Bluetooth Environment” (pg. 30).
Instructions for Windows 7 Users

To install the Bluetooth® drivers:

1. Plug the IOGEAR Bluetooth adapter into an available USB port on your laptop, and wait while Windows installs the required drivers.

   The following message is displayed:

   Installing device driver software.

   When the installation is complete, the following message is displayed:

   Your device is ready to use.

2. Move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 3.

   NOTE:

   If you have installed the IOGEAR Bluetooth adapter, you do not need to perform the last two procedures in this chapter. Move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 3.

If You Installed a Different Class 1 Adapter

If you installed a Class 1 Bluetooth adapter other than the IOGEAR adapter (e.g., a Belkin adapter), the adapter may require you to configure a Bluetooth environment. If this is necessary, an Initial Bluetooth Configuration Wizard screen will display at the conclusion of the adapter installation process.

If this happens, move on to “Configure the Bluetooth Environment” (pg. 30).
Configure the Bluetooth Environment

**IMPORTANT:**

⚠️ You do not need to perform this procedure if you have installed the IOGEAR® Bluetooth adapter. Instead, move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 3 of this manual.

Once you have installed the Bluetooth® adapter, the **Initial Bluetooth Configuration Wizard** is displayed.

![Initial Bluetooth Configuration Wizard](image)

**Figure 2.24 Initial Bluetooth Configuration Wizard**

If the Configuration Wizard does not start up, double-click the **My Bluetooth Places** shortcut on the Windows desktop

To configure a basic Bluetooth® environment:

1. Click **Next**.

   Follow the prompts throughout the configuration process.
During the process the following screen is displayed.

![Bluetooth Service Selection](image)

**Figure 2.25 Bluetooth Service Selection**

2 Clear all of the check boxes except the **Bluetooth Serial Port** check box.

**NOTE:**

You need to use the scroll bar on the right side of the screen to view all of the check boxes.

3 Click **Next**.
4 Click **Skip**.

The Initial Bluetooth Configuration Wizard Congratulations screen is displayed.

5 Click **Finish**.

**Move on to Chapter 3, Preparing to Use the USB-Link™, next in this manual.**
Preparing to Use the USB-Link™

This chapter provides instructions for connecting the USB-Link™ to a vehicle, pairing the device, and testing the connection. It also includes instructions on setting up the diagnostic personal computer (PC) applications supported by the USB-Link™.

- Step 4: Connect the USB-Link™ to a Vehicle, page 34
- Step 5: Pair the Device, page 37
  - Instructions for Windows XP Users, page 37
  - Instructions for Windows 7 Users, page 41
- Step 6: Test the Connection to the Vehicle, page 48
- Step 7: Setting Up Diagnostic PC Applications, page 51
Step 4: Connect the USB-Link™ to a Vehicle

The USB-Link™ interfaces with the vehicle by means of any one of the following connectors:

- 6-pin Deutsch
- 9-pin Deutsch
- 9-pin Deutsch - 1 meter
- 6- and 9-pin Deutsch Y
- 16-pin J1962 for OBD II
- 16-pin J1962 for Heavy Duty

NOTE:
For additional information on choosing the right connector for your situation, refer to Appendix A: USB-Link™ Adapter and Cable Guide, later in this manual.

The following illustration shows how the USB-Link™ connects with the vehicle:

![Wireless USB-Link™-to-Vehicle Connection](image)

Figure 3.1 Wireless USB-Link™-to-Vehicle Connection

NOTE:
A wired connection between the PC and the USB-Link™ is also possible by means of a USB cable (not pictured). Refer to Figure 3.2 for an example of a wired connection.
Making the Connection

There are two connection options:

- Wired connection using a USB cable (pg. 35)
- Wireless connection using a Bluetooth® connection (pg. 36)

Wired Connection Using a USB Cable

To connect the USB-Link™ to a PC or laptop using a USB cable:

1. Connect the USB cable to the USB port of the PC or laptop.

2. Connect the other end of the cable to the port on the device as shown in the following illustration:

3. Connect the DB15 male end of the appropriate adapter cable to the USB-Link™.

4. Attach the other end of the adapter cable (i.e., the Deutsch connector end) to the vehicle’s diagnostic connector.

NOTE:

- The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, or beside the driver’s seat. It can also be located in the engine compartment, near the electronic control unit (ECU).

Move on to “Step 6: Test the Connection to the Vehicle” (pg. 48).
Chapter 3 • Preparing to Use the USB-Link™

Wireless Connection

NOTE:

In some cases you may be prompted to enter a PIN code, or passcode. For Windows 7 this is called a pairing code. If you are prompted to enter a PIN or pairing code, enter NEXIQ (all uppercase).

To connect the USB-Link™ to the vehicle:

1. Connect the DB15 male end of the appropriate adapter cable to the USB-Link™ (see Figure 3.1).

2. Attach the other end of the adapter cable (i.e., the Deutsch connector end) to the vehicle’s diagnostic connector.

NOTE:

The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, or beside the driver’s seat. It can also be located in the engine compartment, near the electronic control unit (ECU).

—At this point, the Power (green) LED on the USB-Link™ should be illuminated (on).

—If the Power LED is not illuminated, turn the vehicle’s key to the ON position, leaving the engine off.

When using a Bluetooth wireless connection, you will hear an alert signal when a PC running an RP1210A or RP1210B compliant application connects and disconnects from the USB-Link™.

In addition, when the USB-Link™ is out of range (more than 100 ft.) of the PC while the application is running, the device will beep and the fault LED will flash until the USB-Link™ is back in range. Plugging the USB cable into the USB-Link™ will silence the out-of-range beep and turn off the flashing fault LED.

Move on to “Step 5: Pair the Device,” next in this manual.
Step 5: Pair the Device

There are two methods for pairing the device:

- Instructions for Windows XP Users (pg. 37)
- Instructions for Windows 7 Users (pg. 41)

Instructions for Windows XP Users

If you are running Windows XP, you use the Bluetooth Connect Utility (assuming that you chose a wireless connection using Bluetooth). The Bluetooth Connect Utility enables you to do the following:

- Select an adapter
- Open a serial connection to the adapter
- Test that the adapter is online and ready to respond

To start the utility, use the Bluetooth Connection Utility icon, which is located on the Windows taskbar.

To use the Connect Utility:

1. From the taskbar on the Windows desktop, right-click the Bluetooth Connect Utility icon.

   The Bluetooth Connect Utility menu appears.

   Figure 3.3 Bluetooth Connect Utility Icon

   Figure 3.4 Bluetooth Connect Utility Menu

2. Click Start Bluetooth Connect Utility.
The Bluetooth Connect Utility - Select a Bluetooth Adapter window is displayed.

![Bluetooth Connect Utility - Select a Bluetooth Adapter](image)

**Figure 3.5 Select a Bluetooth Adapter**

—A list of vehicle adapters on the network is displayed in the data window.

3 From the **Vehicle Adapters available from all devices** list, select the vehicle adapter to which you want to connect (e.g., **USBL-035957 VEHICLE ADAPTER**).
The following screen is displayed.

![Bluetooth Connect Utility - Select a Bluetooth Adapter](image)

**Figure 3.6 Adapter Selection**

4 Click **OK** to confirm the selection.

The utility performs the steps to ensure that the *Bluetooth* adapter is ready for communication with the USB-Link™.

The utility also opens a serial connection to the device and tests to make certain that the device is online and ready to respond.
Chapter 3 • Preparing to Use the USB-Link™

The results of these tests are displayed in the lower right corner of the screen (e.g., **ADAPTER SELECTION PASSED**).

![Adapter Confirmation](image)

**Figure 3.7 Adapter Confirmation**

At this point, you have several options.

— Click **Close** to close the Bluetooth Connect Utility.

— If you want to select a different vehicle adapter (i.e., USB-Link™) from among those displayed, select the adapter from the list, and click **OK**.

— If you want to search for a different adapter not included in the display (e.g., you just connected another USB-Link™ to a vehicle), click **Refresh** and make your selection from the newly displayed list.

Move on to “Step 6: Test the Connection to the Vehicle” (pg. 48).
Instructions for Windows 7 Users

If you are running Windows 7, you use the Windows 7 utility to pair the device (assuming that you chose a wireless connection using Bluetooth).

To pair the device:

1. Locate the Bluetooth icon from the system tray on your laptop’s desktop.

2. Click on the Bluetooth icon.

3. Click Add a Device.
The **Add a device** screen is displayed.

![Image](image_url)  

**Figure 3.10 Add a Device Screen**

4. Select the device displayed that matches the serial number on the back of your USB-Link™ (e.g., **USBL-012291**).
Your selection is highlighted.

**Figure 3.11 Add a Device Screen Refreshed**

5 Click **Next**.
The **Select a pairing option** screen is displayed.

![Select a Pairing Option Screen](image)

**Figure 3.12 Select a Pairing Option Screen**

6 Select **Enter the device’s pairing code**.
The **Enter the pairing code for the device** screen is displayed.

![Figure 3.13 Enter the Pairing Code for the Device Screen](image)

7 Enter NEXIQ.
Be sure to enter the code in ALL CAPS.

8 Click **Next**.
The following System Tray message is displayed.

*Your device is ready to use.*

9 Click **Close**.

Move on to “Step 6: Test the Connection to the Vehicle,” next in this manual.
Step 6: Test the Connection to the Vehicle

You use the Device Tester to test the connection between the USB-Link™ and the vehicle. At startup, the Device Tester checks for any NEXIQ™ drivers installed on the PC.

Access the Device Tester from the Windows taskbar.

To test the connection between the USB-Link™ and the vehicle:

1. Click Start and then select Programs ▶ NEXIQ ▶ Device Tester ▶ Device Tester.

   The application is started and the Device Tester screen is displayed.

   ![Device Tester Screen, Showing a Status of Not Connected](image)

   - **Figure 3.16 Device Tester Screen, Showing a Status of Not Connected**

2. Use the button in the Device box to select the appropriate device (for example, USB-Link).

   — The Device box lists all the devices supported by the NEXIQ drivers installed on the PC.

3. Use the button in the Protocol box to select the appropriate protocol (e.g., J1708, J1939, or CAN).
—The Protocol box lists only the protocols supported by the device selected in the Device box.

4 Press the Start Test button.

The Device Tester screen is refreshed, and data received from the vehicle bus is displayed in the Bus Messages window.

NOTE:

The Modules Detected window in the lower portion of the screen displays a list of all systems seen on the bus. It is used for J1708 and J1939 only. For all other protocols this window will be unavailable (i.e., NOT USED).
If the Connection Indicator button is red (i.e., Not Connected), do one of the following:

—For wireless connection using Bluetooth technology:
   • In the Device list, make sure that the heading is BLUETOOTH USB-Link (Protocol desired).
   • Check to ensure that the connections between the USB-Link™ and the vehicle are secure (i.e., the Diagnostic Connector).
   • Check to make certain that the Power LED on the USB-Link™ is illuminated.
   • Check to make sure you are “paired” with devices.
—For wired connection using a USB cable:
   • In the Device list, make sure that the heading is USB-Link (Protocol desired).
   • Check to ensure that the connections between the USB-Link™ and PC are secure (i.e., the USB cable).
   • Check the connections between the USB-Link™ and the vehicle (i.e., the Diagnostic Connector).
   • Check to make certain that the Power LED on the USB-Link™ is illuminated.

NOTE:
For additional information, refer to “Connect the USB-Link™ to a Vehicle” on page 34 of this manual.

5 Click Stop Test to end the test, or select another device to test.
Step 7: Setting Up Diagnostic PC Applications

The diagnostic applications supported by the USB-Link™ use varying methods of vehicle communication device selection. This section provides instructions for configuring some of the PC diagnostic applications currently available for use with the NEXIQ USB-Link™.

NOTE:
The instructions provided here are based on the application settings at the time this guide was developed.

NOTE:
If you need assistance setting up these diagnostic PC applications, contact NEXIQ Technical Support at 1-800-639-6774, or visit us online at http://www.nexiq.com/support.

Allison DOC™ for Fleets (1000/ 2000)

1. From the PC’s desktop, click Start then select Programs ▸ Allison Transmission ▸ Allison DOC 1K2K Lite.

   The Allison Transmission screen appears.

2. Click Connect to Vehicle.

   The Transmission Connect/Disconnect screen appears.

3. Click on the radio button () next to the Transmission Type field, then select the desired transmission type.

4. Click on the ▪ next to the Vendor field, then select NXULNK32.

5. Click on the ▪ next to the Protocol field, then select J1939.

6. Click on the ▪ next to the Device field, then select USB-Link J1939 if connection is wired; select BT USB-Link J1939 if the connection is wireless.

7. Click Connect.
**Allison DOC™ for Fleets (3000/4000)**

1. From the desktop, click **Start** then select **Programs** ➤ **Allison Transmission** ➤ **Allison World Transmission Lite**.

   The **Allison Transmission** screen appears.

2. Click **Connect to Vehicle**.

   The **Transmission Connect/Disconnect** screen appears.

3. Click on the radio button (⊙) next to the **Transmission Type** field, then select **WTEC Series**.

4. Click on the ▼ next to the **Vendor** field, then select **NXULNK32**.

5. Click on the ▼ next to the **Protocol** field, then select **J1708**.

6. Click on the ▼ next to the **Device** field, then select **USB-Link J1708** if the connection is wired; select **BT USB-Link J1708** if the connection is wireless.

7. Click **Connect**.

**Allison DOC™ for PC (update)**

1. From the PC’s desktop, click **Start** then select **Programs** ➤ **Allison Transmission** ➤ **Allison DOC 1K2K Lite**.

   The **Allison Transmission** screen appears.

2. Click **Connect to Vehicle**.

   The **Transmission Connect/Disconnect** screen appears.

3. Click on the radio button (⊙) next to the **Transmission Type** field, then select the desired transmission type.

4. Click on the ▼ next to the **Vendor** field, then select **NXULNK32**.

5. Click on the ▼ next to the **Protocol** field, then select **J1939**.

6. Click on the ▼ next to the **Device** field, then select **USB-Link J1939** if connection is wired; select **BT USB-Link J1939** if the connection is wireless.

7. Click **Connect**.
**Bendix Acom™ Diagnostics**

**NOTE:**

Complete the steps in the following procedure *before* attempting to run this application.

1. From the PC’s desktop, click **Start** then select **Programs ▸ Bendix ▸ Acom Diagnostics NAD**.

   The ACom main screen is displayed.

![ACom main screen](image)

**Figure 3.18 ACom main screen**

2. Click **Vehicle Interface Adapter**.
Chapter 3 • Preparing to Use the USB-Link™

The New Session... screen is displayed with the Select Control Unit tab activated.

![New Session... screen with Select Control Unit activated]

3 From the **Name** column, select the appropriate brake system (e.g., **EC-30 J1537**).

4 Click **OK**.

![Diagnostic Interface Selection dialog box.]

5 Check the box for the appropriate interface.

For example, select **RP1210A device using J1708 line: BTUSBLINK (BT USB-Link J1708)** for a wireless connection, **RP1210A device using J1708 link: USBLINK (USB-Link J1708)** for a wired connection.

6 Click **OK**.
7. Click **Vehicle Interface Adapter**.

   The **Diagnostic Interface Selection** screen appears.

8. Under **Available hardware interfaces**: use the drop-down list box to select one of the following:

   — Select **RP1210A device using J1708 line: BTUSBLINK (BT USB-Link J1708)** for wireless connection.

   — Select **RP1210A device using J1708 line: USBLINK (USB-Link J1708)** for wired operation.

9. Click **OK**.

### Caterpillar Electronic Technician

1. From the PC’s desktop, click **Start** then select **Programs** ➤ **Caterpillar ET** ➤ **Electronic Technician**.

2. Before the system has time to connect, click **Stop Connect**.

---

*Figure 3.21* CAT ET Connect screen
3 Click **Utilities** ➤ **Preferences** on the screen’s menu bar.

![Figure 3.22 Portion of CAT main screen with Utilities Preferences selected](image1)

4 Click on the **Communications** tab then select **RP1210 Compliant Device** from the drop-down list.

5 Click the **Advanced...** button to select a specific RP1210 compliant device.

![Figure 3.23 Preferences screen](image2)
6 Click on the at the top of the screen to select the appropriate device.

For example, select USB-LINK for a wireless connection.

7 Click OK.

8 Click OK again.

NOTE:

Prior to connecting for the first time, use the NEXIQ Device Tester (refer to page 48 in this manual) to test the connection to the vehicle for this device.
Cummins INSITE™

**NOTE:**

![Supports calibrating ECMs on J1708 or J1939.]

**NOTE:**

Complete the steps in the following procedure before attempting to run this application.

1. From the PC’s desktop, click **Start** then select **Programs** ▶ **Intellect** ▶ **Cummins INSITE**.

   The application screen appears.

2. Click on **File** ▶ **Connections** ▶ **Add New Connection**.

   The Connection Wizard screen appears.

3. Click **Next**.

   The screen prompts you to select a connection type.

![ECM Connection Wizard Connection Type screen](image)

**Figure 3.25 ECM Connection Wizard Connection Type screen**

4. Click on the radio button (❑) for **RP1210A**.

---

58  USB-Link™ Installation and Setup Manual
5 Click Next.

The screen prompts you to select an RP1210A adapter type.

![ECM Connection Wizard RP1210A Adapter Type screen](image)

**Figure 3.26 ECM Connection Wizard RP1210A Adapter Type screen**

6 Select the adapter type you wish to use.

For example, **BT USB-Link J1708** for a wireless connection, or **USB-LINK J1708** for a wired connection.

7 Click Next. The Wizard displays the “Connection Name.”
   —If you want to change the name in the **Connection Name** box, type in the desired name.

8 Click Next.
The screen prompts you to indicate whether you want to make this connection active or set up another connection.

9  Click on the first check box (☐) (labeled “To make this connection active...”)

10  Click Finish.

11  Verify that the selections you made are “active” by checking the message in the System Tray in the lower right corner of your desktop.

Figure 3.27 ECM Connection Wizard

Figure 3.28 System Tray indicating Bluetooth USB-Link J1708
Detroit Diesel Diagnostic Link (DDDL)™

NOTE:

Complete the steps in the following procedure before attempting to run this application.

1. From the PC’s desktop, click Start then select Programs ▶ Detroit Diesel ▶ Options.
2. On the Welcome to DDDL screen, click Close.
3. From the menu bar at the top of the screen, click Tools ▶ Options.
   The Options screen is displayed.

   ![Figure 3.29 Options screen](image)

4. Click the Interface tab.
5. Click on the ▼ under Local Communications Interface to select the appropriate interface.
   For example, select BT USB-Link J1708 for a wireless connection, or USB-Link J1708 for a wired connection.
6. Click OK.
DDEC 7.0

NOTE:

Complete the steps in the following procedure before attempting to run this application.

1. From the PC's desktop, click Start ▶ Programs ▶ Detroit Diesel ▶ Diagnostic Link ▶ SIDConfigure.exe.

2. Select Device (e.g., NEXIQ USB Link CAN1).

3. Click OK.
Eaton Service Ranger

1. From the PC’s desktop, click **Start** then select **Programs** → **Service Ranger** → **Service Ranger**.

2. ServiceRanger asks you whether you want to connect to the vehicle now.

3. Click **No**.

   The **ServiceRanger Main Menu** is displayed.

![ServiceRanger Main Menu](image)

4. Click on **Utilities** at the top of the screen, then select **View/Change Communications Settings**.
Chapter 3 • Preparing to Use the USB-Link™

The **Communications Hardware** screen is displayed.

![Communications Hardware screen](image)

**Figure 3.31 Communications Hardware screen**

5 Select the appropriate adapter. For example, select **BT USB-Link J1708**, for a wireless connection, or **USB-Link J1708** for a wired connection.

6 Click **OK**.
HI NO Diagnostic eXplorer

NOTE:

Complete the steps in the following procedure before attempting to run this application.

1. From the PC's desktop, click Start then select Programs ▶ HINO Diagnostic eXplorer ▶ Options.
2. Type your password in the Password box.
3. Click OK.
   The HINO Diagnosis screen is displayed.

4. Click on Option(s) at the top of the screen, and select Communication(D).

Figure 3.32 Hino Diagnosis screen
5 Click on the ‑ next to the **Select Communication Interface** box, and select the appropriate interface.

6 Click **OK**.
International® ABS

1. From the PC’s desktop, click Start then select Programs ▶ Vehicle Diagnostics ▶ ABS.

The International Hydraulic ABS screen is displayed.

2. On the screen’s menu bar, click Tools ▶ Hydraulic ABS Settings ▶ COM Device... .

3. Click on NEXIQ (NNT, Inc.) USB-Link, then click OK.
Chapter 3 • Preparing to Use the USB-Link™

4 Click on the appropriate device.

For example, select **BT USB-Link ALDL Pass-through** for a wireless connection, or **USB-Link ALDL Pass-through** for a wired connection.

5 Click **OK**.
International® INTUNE

1. From the PC’s desktop, click Start then select Programs ▶ Vehicle Diagnostics ▶ INTUNE.

   The INTUNE application screen appears.

2. Click on the File menu, then select Settings ▶ Com Device...

   The screen prompts you to enter a communication DLL.

3. Click on NEXIQ (NNT, Inc.) USB-Link, then click OK.

   The screen prompts you to select a communication device.

4. Click on USB-Link J1939, then click OK.

International® Three, Single, and Dual Box

1. From the PC’s desktop, click Start then select Programs ▶ Vehicle Diagnostics.

2. Select the application (e.g., MD32 3BX, DLC, or DLC II).

   The application main screen is displayed.

3. On the screen’s menu bar, click File ▶ MD Settings ▶ COM Device.

   **Figure 3.37** Top portion of application main screen showing COM Device selection
4 Click on **NEXIQ (NNT, Inc.) USB-Link**, then click **OK**.

![Select a device screen](image1)

**Figure 3.38 Select a device screen**

5 Click on the appropriate device.

For example, select **BT USB-Link J1708** for a wireless connection, or select **USB-Link J1708** for a wired connection.

6 Click **OK**.
Meritor WABCO® Toolbox

1. From the PC’s desktop, click Start then select Programs ▶ Meritor WABCO ▶ Meritor WABCO PC Diagnostics.

The Meritor WABCO PC Diagnostics screen is displayed.

2. Click on the System Setup menu item, then select COM Port.

The Device Settings screen is displayed.
3 Under **Vendor**, click on the ▼ to select the appropriate vendor. For example, **NEXIQ (NNT, Inc.) USB-Link**.

4 Under **Protocol**, click on the ▼ to select the appropriate protocol. For example, **J1708** or **J1939**.

5 Under **Device**, click on the ▼ to select the appropriate device. For example, select **BT USB-Link J1708**, for a wireless connection, or **USB-Link J1708** for a wired connection.

6 Click **OK**.
USB-Link™ Troubleshooting Information

- LED Issues, pg. 74
- Configuration Issues, pg. 76
- Wireless Communication Issues, pg. 76

This chapter provides troubleshooting information to assist you in resolving issues that may arise when setting up and using the USB-Link™.
### LED Issues

The following table provides some possible causes and solutions to issues related to the USB-Link’s light-emitting diodes (LEDs).

<table>
<thead>
<tr>
<th>Problem</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power LED on the USB-Link™ does not come on if USB cable is hooked up.</td>
<td>Loose or faulty cable or adapter.</td>
<td>Check to make certain that the USB cable is plugged into the PC.</td>
</tr>
<tr>
<td>No power on the USB-Link™ when the vehicle adapter is plugged into the device.</td>
<td>Bad connection. Vehicle power off.</td>
<td>Make sure that the connector on the vehicle has power on the proper terminals.</td>
</tr>
</tbody>
</table>
| Power LED does not light, the USB cable is connected, and the vehicle cable is disconnected. | On occasion, Windows power management removes power from the USB bus.        | • From the Control Panel on the PC, select System -> Hardware -> Device Manager -> Universal Serial Bus Controllers -> USB Root Hub -> Properties -> Power Management. Make certain that the “Allow the computer to turn off this device to save power” check box is clear (☐).  
• To attempt correction: Place the laptop in Stand by mode, then press the Power button to restore to Operating mode. USB power should be restored. |

<table>
<thead>
<tr>
<th>Problem</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Problem</td>
<td>Possible Cause</td>
<td>Solution</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Flashing Power Light</td>
<td>Loose or faulty cable</td>
<td>• Check cable connections at USB-Link and Vehicle.</td>
</tr>
<tr>
<td></td>
<td>Bad connection</td>
<td>• Make sure that connector on vehicle has power on the proper terminals.</td>
</tr>
<tr>
<td></td>
<td>Vehicle power off</td>
<td>• Make sure that connector on vehicle has power on the proper terminals. Make sure vehicle power is on.</td>
</tr>
<tr>
<td></td>
<td>No ground on vehicle adapter</td>
<td>• Make sure that connector on vehicle has power on the proper terminals.</td>
</tr>
<tr>
<td></td>
<td>No battery + on vehicle adapter</td>
<td>• Make sure that connector on vehicle has power on the proper terminals.</td>
</tr>
</tbody>
</table>
Configuration Issues

The following table provides some possible causes and solutions to issues that may be experienced when configuring the USB-Link™ and/or PC for wireless communication.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC applications produce communication errors when trying to connect to the USB-Link™.</td>
<td>Not set up for USB-Link™.</td>
<td>Under the application that is in use, check user options to verify that the USB-Link™ has been selected.</td>
</tr>
<tr>
<td>Unable to find the USB-Link™ in the application menu.</td>
<td>USB-Link™ drivers not installed or supported.</td>
<td>Reinstall device drivers, restart the PC, and check again for the device.</td>
</tr>
<tr>
<td>The PC does not recognize the USB-Link™ after restarting the PC.</td>
<td></td>
<td>Unplug the USB-Link™ and restart the PC. Plug the USB cable back into the PC.</td>
</tr>
</tbody>
</table>

Wireless Communication Issues

The following table lists some possible causes and solutions to issues that may be experienced when attempting to set up the USB-Link™ to use wireless communication.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unable to find Bluetooth Network</td>
<td>Make certain that the dongle is plugged into the machine and that the device drivers are loaded.</td>
<td></td>
</tr>
</tbody>
</table>
This appendix provides a guide to USB-Link™ cable adapters and their NEXIQ™ part numbers. It also provides the NEXIQ™ part number for the 15 ft. USB cable you’ll need if you opt for wired communication between the USB-Link™ and your PC.
Choosing the Right Cable Adapter

The following table enables you to choose the right USB-Link™ cable adapter for your situation. It shows connectors, protocols, and the associated NEXIQ part numbers:

*Table-A-1. USB-Link™ Adapters*

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>6-pin Deutsch</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(Part No. 402096)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9-pin Deutsch</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>(Part No. 405097)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9-pin Deutsch - 1 meter</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>(Part No. 408001)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6-pin Deutsch and</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9-pin Deutsch</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>(Part No. 405048)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16-pin J1962 (OBD II)</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>(Part No. 448013)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16-pin J1962 (Heavy Duty)</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(Part No. 444009)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Notes:

• 6-pin Deutsch—1995 to present (Class 6-8 Heavy Duty OEM and Tier 1 suppliers)

• 9-pin Deutsch—1998 to present (Class 6-8 Heavy Duty OEM and Tier 1 suppliers)

• 16-pin J1962 (Heavy Duty)—1996 to present (GM C6500 with Caterpillar engine) (Ford F series with Caterpillar or Cummins engine)

• ALDL—Kelsey Hayes, Lucas Varity, and TRW Ross Hydraulic ABS brakes found on International, GM C5500+, and Ford F6500 models

• Part number 403098—15 ft. USB cable

Adapter Drawings

The following figures (Figures 1 through 6) are arranged by part number. They illustrate the USB-Link™ cable adapters discussed above.
Figure A.3 Part No. 405097—9-pin Deutsch

Figure A.4 Part No. 408001—9-pin Deutsch - 1 meter

Figure A.5 Part No. 405048—6 and 9-pin Deutsch "Y"
Choosing the Right Cable Adapter

**Figure A.6** Part No. 448013—16-pin J1962 for OBD II

**Figure A.7** Part No. 444009—16-pin J1962 for Heavy Duty